业务咨询热线
18923788188

新闻资讯
深圳市王网科技有限公司 > 王网新闻 > 公司新闻 >

H3C交换机VLAN、Trunk、STP、VRRP、OSPF、DHCP中继、SSH应考配置教程

文章出处:未知作者:sz81101099发表时间:2017年12月16日 19:10:19

H3C交换机VLAN、Trunk、STP、VRRP、OSPF、DHCP中继、SSH应考配置教程

H3C交换机VLAN、Trunk、STP、VRRP、OSPF、DHCP中继、SSH应考配置教程

SYS       进入系统
SYSN SW1  改名
VLAN 10   创建VLAN 10

DISPLAY CU INT  查看接口的状态  roeter路由(三层接口)、bridge交换、access接入、trunk中继
交换机连接交换机都是trunk
trunk就是给有vlan信息的数据帧打上tagget标签,让交换机与交换机之间的vlan互通
int gi0/0/1
port link-mode bridge 先将接口的路由状态改为交换
port link-type access
port access vlan 10
将交换机G0/0/0改成trunk只允许vlan 10通过
int gi0/0/0
port link-mode bridge 先将接口的路由状态改为交换(二层接口)
port link-type trunk
port trunk permit vlan 1 10 只允许vlan 1 10通过
不让Gi0/0/0中继vlan 1通过
undo port trunk permit vlan 1
查看有vlan和接口
dis cu int gi0/0/0 查看接口的配置
display vlan  10  查看vlan
Tagged Port:
  GigabitEthernet0/0/0  中继 vlan 10的接口
Untagged Port:    vlan 10下的接口
Ethernet0/0/1
=====================================
需求三个交换机上创建vlan 10,20,30,40
要求配置生成树协议
SW1作为10  20的根桥
SW2作为30  40的根桥
SW1/SW2/SW3
vlan 10
vlan 20
vlan 30
vlan 40
验证    dis vlan
给VLAN配置IP 地址
SW1
int vlan 10
ip add 10.10.1.253 24
undo sh
int vlan 20
ip add 10.20.1.253 24
int vlan 30
ip add 10.30.1.253 24
int vlan 40
ip add 10.40.1.253 24
SW2
int vlan 10
ip add 10.10.1.254 24
undo sh
int vlan 20
ip add 10.20.1.254 24
int vlan 30
ip add 10.30.1.254 24
int vlan 40
ip add 10.40.1.254 24
查看配置  dis cu int vlan 10

把交换机互联接口改成中继模式,允许10,20,30,40VLAN通过
int e0/4/0
port link-type trunk
port trunk permit vlan 10 20 30 40
dis this 查看
int e0/4/1
port link-type trunk
port trunk permit vlan 10 20 30 40
---------------
配置生成树的时候,三个交换机必须配置相同的实例,而且开启生成树功能
stp enable
配置实例原则:
网络中有几个根桥,就配几个实例
做VLAN的根桥,要把VLAN配置到一个实例中
SW1
stp region-configuration  进入生成树配置
region-name WANGW 创建stp实例名
instance 1 vlan 10 20  实例1里有VLAN 10 20
instance 2 vlan 30 40  实例2里有VLAN 30 40
active region-configuration  激活配置
dis this 查看
配置SW1成为 vlan10 20 的根桥
SW1
stp instance 1 priority 0 实例的优先级为0
配置SW2成为 vlan30 40 的根桥
SW2
stp instance 2 priority 0
查看详细
display stp instance 1
查看简单的
display stp instance 1 brief
DESI代表指定端口,而根桥上的端口全是指定端口
ROOT代表根端口,ALTE替代端口(被阻塞的端口)
STP接电脑终端的都改成边缘接口,这样一台电脑关机不会因网络拓普改变而断网
int e0/4/2
stp edged-port enable 将0/4/2开启边缘接口
====================================
配置VRRP,SW1作为VLAN10 20 主用设备,SW2作为VLAN30 40的主用设备
VRRP通常要和生成树一起配置
某个VLAN的根桥一定要和VRRP的主用设备位于同一台设备
1、配置VRRP需要漂移地址,漂移地址作为当前VLAN的默认网关
漂移地址必须和当前VLANIF的IP在一个网段,但是,不能和当前的IP地址相同
vrrp vrid 10virtual-ip 指定漂移地址
主备交换机的漂移地址必须相同
sys
int vlan 10
vrrp vrid 10 virtual-ip 10.10.1.1
2、配置优先级和占先级,主用设备的优先级高于备用设备
优先级默认值是100   主备的差值不能太大,差10就行了
SW1
vrrp vrid 10 priority 120
SW2
vrrp vrid 10 priority 110
再配置占先权
vrrp vrid 10 preempt-mode  默认情况下是有这个命令一般不用配
配置跟踪对象
在主用设备上面跟踪对象,一旦对象失效,就降低一定的优先级
降到比备用设备的优先级更低
vrrp vrid 10 track  接口  降低的值
VLAN 20的配置
SW1
int vlan 20
vrrp vrid 20 virtual-ip 10.20.1.1  漂移IP地址
vrrp vrid 20 priority 120 指定SW1优先级为120
vrrp vrid 20 preempt-mode
----------------
SW2
int vlan20
vrrp vrid 20 virtual-ip 10.20.1.1
vrrp vrid 20 priority 110指定SW1优先级为110
查看VRRP
dis vrrp
----------------
VLAN 30
SW1
int vlan 30
vrrp vrid 30 virtual-ip 10.30.1.1
vrrp vrid 30 priority 80
查看dis cu int vlan 30
int vlan 40
vrrp vrid 40 virtual-ip 10.40.1.1
vrrp vrid 30 priority 80
查看dis cu int vlan 40
SW2
int vlan 30
vrrp vrid 30 virtual-ip 10.30.1.1
vrrp vrid 30 priority 90

int vlan 40
vrrp vrid 40 virtual-ip 10.40.1.1
vrrp vrid 40 priority 90
给交换机配置Loopback接口地址
SW1:10.1.1.1
SW2:10.2.2.2
SW3:10.3.3.3
SW1:int lo 0
    ip add 10.1.1.1 32
SW2:int lo 0
    ip add 10.2.2.2 32

SW3:int lo 0
    ip add 10.3.3.3 32

----------------------
配置OSPF路由协议使得全网互通
SW1
ospf 123 router-id 10.1.1.1
area 0.0.0.0
dis ip routing-table protocol direct 查看有的网段
network 10.1.1.1 0.0.0.0
network 10.10.1.0 0.0.0.255
network 10.20.1.0 0.0.0.255
network 10.30.1.0 0.0.0.255
network 10.40.1.0 0.0.0.255
quit
dis this
SW2
ospf 123 router-id 10.2.2.2
area 0.0.0.0
network 10.2.2.2 0.0.0.0
network 10.10.1.0 0.0.0.255
network 10.20.1.0 0.0.0.255
network 10.30.1.0 0.0.0.255
network 10.40.1.0 0.0.0.255

SW3
ospf 123 router-id 10.3.3.3
area 0.0.0.0
dis ip routing-table protocol direct
network 10.3.3.3 0.0.0

dis ip routing-table ospf 查看ospf路由
SW3没有配置VLAN和IP不通
--------------------------------
SW1、SW2、SW3开启SSH远程访问
用户级别设置为0
要求输入super密码以后才可以使用system-view
SW1
ssh server enable  先启用ssh服务
再创建用户和密码
local-user WANGW
再设置用户属性
server-type ssh
authorization-attribute level 0 级别0
password cipher(密文) wangw
user-interface vty 0 4
authentication-mode scheme 修改认证方式为用户名和密码
protocol inbound ssh 修改协议
user privilege 0  用户级别为0
生成密钥对
public-key local create rsa
设置super密码
super password cipher wangw 提高权限的密码
------------------------------------------------
需求描述:RT1作为DHCP服务器,创建2个全局地址池
192.168.10.0/24
192.168.20.0/24
在交换机上配置DHCP中继,确保RT2和RT3都能从RT1处获取IP地址
1、交换机上创建2个VLAN
vlan 10
vlan 20
2、给vlan配置上IP地址,作为RT、1RT、2RT3的网关
interface vlan 10
ip add 192.168.10.1 24
interface Vlan-interface20
ip address 192.168.20.1 255.255.255.0
3、把接口加入相应的VLAN
int e0/4/0
port link-type access
port access vlan 10
int e0/4/1
port access vlan 10
int e0/4/2
port access vlan 20

4、配置RT1,配置IP地址和默认网关


int gi0/0/0
ip add 192.168.10.2 255.255.255.0接口地址
ip route-static 0.0.0.0 0.0.0.0 192.168.10.1默认路由
5、配置2个全局地址池
dhcp enable 启DHCP服务
第一个全局地址池
dhcp server ip-pool VLAN10 创建地址池名
network 192.168.10.0
gateway-list 192.168.10.1 分配网关
dns-list 202.96.134.133 8.8.8.8   指定DNS
第二个全局地址池
dhcp server ip-pool vlan20
network 192.168.20.0
gateway-list 192.168.20.1
dns-list 202.106.0.20 8.8.8.8

int gi0/0/0
ip add dhcp-alloc 这个接口的地址由DHCP分配

6、配置DHCP中继,中继配置在服务端的出口方向,客户端的入口方向
如果客户端连接在路由器的G0/0/1口上,则在G0/0/1上做中继
如果客户端连接在属于VLAN20的接口上,则在VLAN20上做中继
SW1
dhcp enable
dhcp relay server-group 1 ip 192.168.10.2 指定服务器的地址
int vlan 20
dhcp select relay
dhcp relay server-select 1 中继1
dhcp relay client-detect enable
dis this
再去RT2上看有没有获取IP
dis ip intface bri
dis ip routing-table 查路由信息

7、客户端配置和验证
ip add dhcp-alloc
dis ip int br
===================================
案例:
需求描述
1、创建2个VLAN,分别是VLAN 10和VLAN 20
2、SW1作为VLAN 10的根桥,SW2作为VLAN 20的根桥
3、配置VRRP
VLAN 10 10.10.1.0/24
VLAN 20 10.20.1.0/24
要求,SW1作为VLAN 10的主用设备,SW2作为VLAN 20的主用设备
4、SW1和SW2、RT1的Loopback接口地址
SW1   10.1.1.1
SW2   10.2.2.2
RT1   1.1.1.1
要求配置OSPF使得2台设备的Loopback接口互通
5、在RT1上开启SSH远程访问功能
用户名 WANGW   密码  wangw
让RT2通过SSH远程访问到RT1上,RT2属于VLAN 10
6、RT2的接口地址通过DHCP获取,R1做SHCP服务器

先创建VLAN 连接交换机的口改成TRUNK
注意:如果没有特殊要求,应该让所有交换机上的VLAN保持一致
SW1
vlan 10
vlan 20
int e0/4/1
port link-type trunk
port trunk permit vlan 10 20
int e0/4/2
port link-type trunk
port trunk permit vlan 10 20
SW2
vlan 10
vlan 20
int e0/4/1
port link-type trunk
port trunk permit vlan 10 20
int e0/4/2
port link-type trunk
port trunk permit vlan 10 20
SW4
vlan 10
vlan 20
int e0/4/0
port link-type trunk
port trunk permit vlan 10 20
int e0/4/1
port link-type trunk
port trunk permit vlan 10 20
int e0/4/2
port access vlan 10
stp edged-port enable 将这个接终端的接口设成边缘接口,这个终端下线不影响网络拓普

再配STP生成树
SW1
stp enable
stp region-coniguration 进入到多生成树的配置视图下
region-name WANGW 命名
instance 1 vlan 10 做一个VLAN10的根桥
instance 2 vlan 20 做一个VLAN20的根桥
active region-configuration 激活配置,不激活就dis this 查不到

关闭显示很多不必要的信息
re
u t m

SW2
stp enable
stp region-coniguration 进入到多生成树的配置视图下
region-name WANGW 命名
instance 1 vlan 10 做一个VLAN10的根桥
instance 2 vlan 20 做一个VLAN20的根桥
active region-configuration 激活配置,不激活就dis this 查不到

关闭显示很多不必要的信息
re
u t m

SW4
stp enable
stp region-coniguration 进入到多生成树的配置视图下
region-name WANGW 命名
instance 1 vlan 10 做一个VLAN10的根桥
instance 2 vlan 20 做一个VLAN20的根桥
active region-configuration 激活配置,不激活就dis this 查不到

关闭显示很多不必要的信息
re
u t m
--------------------------
再配优先级
SW1
stp instance 1 pri 0
stp instance 2 pri 4096  必须是4096的倍数
SW2
stp instance 1 pri 4096
stp instance 2 pri 0  必须是4096的倍数

查看dis stp instance 1 bri
---------------------
再配VLAN IP 主用设备
SW1
int vlan 10
ip add 10.10.1.253 255.255.255.0
vrrp vrid 10 virtual-ip 10.10.1.1
vrrp vrid 10 pri 90
int vlan 20
ip add 10.20.1.253 255.255.255.0
vrrp vrid 20 virtual-ip 10.20.1.1
vrrp vrid 20 priority 70
SW2
int vlan 10
ip add 10.10.1.254 255.255.255.0 漂移地址不能与主用地址相同
vrrp vrid 10 virtual-ip 10.10.1.1
vrrp vrid 10 priority 70
int vlan 20
ip add 10.20.1.254 255.255.255.0
vrrp vrid 20 virtual-ip 10.20.1.1
vrrp vrid 20 priority 90
dis vrrp
-----------
配Loopback接口
SW1
int lo 0
ip add 10.1.1.1 32
SW2
int lo 0
ip add 10.2.2.2 32

配置RT1
先配置SW1的e0/4/0接口进VLAN 10
int e0/4/0
port access vlan 10
再在SW2的e0/4/0接口划入VLAN 20
int e0/4/0
port access vlan 20
再在RT1上给2个接口配对应VLAN的IP
RT1
sys
int gi0/0/0
ip add 10.10.1.2 255.255.255.0
int gi0/0/1
ip add 10.20.1.2 255.255.255.0
再配OSPF
SW1
ospf 100
area 0 配区域
network 10.1.1.1 0.0.0.0
network 10.10.1.0 0.0.0.255
network 10.20.1.0 0.0.0.255

SW2
ospf 100
area 0 配区域
network 10.2.2.2 0.0.0.0
network 10.10.1.0 0.0.0.255
network 10.20.1.0 0.0.0.255

RT1
ospf 100
area 0
network 1.1.1.1 0.0.0.0
network 10.10.1.0 0.0.0.255
network 10.20.1.0 0.0.0.255
------------------------------------------
在RT1上开启SSH远程访问功能
RT1
ssh server enable
local-user WANGW
passwork cipher wangw
authorization-attribute level 0
service-type ssh
quit
user-interface vty 0 4
authentication-mode scheme
protocol inbound ssh
quit
public-key local create rsa
int lo 0
ip add 1.1.1.1

--------
dhcp enable
dhcp server ip-pool vlan10
network 10.10.1.0 mask 255.255.255.0 A类的网段必须带掩码,不然就当是A类的网段了
gateway-list 10.10.1.1网关给漂移地址

dis this
---------------------
RT2
sys
int gi 0/0/0
ip add dhcp-alloc
quit

www.weipan808.com
友情链接:中国福彩网  中国福彩网  中国福彩网  中国福彩网  中国福彩网  中国福彩网  中国福彩网  中国福彩网  中国福彩网  中国福彩网  中国福彩网  中国福彩网  中国福彩网  中国福彩网  中国福彩网  中国福彩网  中国福彩网  中国福彩网  中国福彩网  中国福彩网